Estoy trabajando con Ruby pero me sale el error: 'require' cannot load such file (LoadError). ¿Como lo corrijo?

Fecha de modificación: Jue., 1 Feb., 2018 at 5:27 PM


Al iniciar la integración de Conecta en tu proyecto, debes asegurarte que estas usando el ambiente correcto. 

En la siguiente imagen se muestra un error debido a usar una versión de Ruby no compatible con nuestra librería.




En todos los lenguajes recomendamos tener la versión anunciada en el repositorio de Github.


Para revisar tu versión puedes correr desde la terminal

ruby -v


Una forma fácil de control la versión de Ruby que usas para tu proyecto es con un ambiente "virtual" como Ruby Version Manager (RVM) 


Por ejemplo:

rvm use 2.3.0


También es importante que la versión de la librería de Conekta esté actualizada. Puedes revisar la última versión aquí en GitHub

 

En tu archivo de Gemfile agrega esta línea:

gem 'conekta'


Y en el terminal corra:

$ bundle



Otra opción es instalar la gema directamente en la terminal:

$ gem install conekta



Cuando hayas realizado todos los pasos anteriores, deberías estar listo para probar tu integración.

Sigue la documentación de GitHub o nuestros tutoriales. También puedes revisar ejemplos en nuestra API Reference.


Descarga las librerías de programación actualizadas.  




¿Le resultó útil? No

Enviar comentarios
Le pedimos disculpas por no haber podido ayudarlo. Envíenos sus comentarios y ayúdenos a mejorar este artículo.